目 录CONTENT

文章目录

829.模拟队列

不争
2024-01-02 / 0 评论 / 0 点赞 / 10 阅读 / 1660 字

829.模拟队列

实现一个队列,队列初始为空,支持四种操作:

  1. push x – 向队尾插入一个数 xx;
  2. pop – 从队头弹出一个数;
  3. empty – 判断队列是否为空;
  4. query – 查询队头元素。

现在要对队列进行 MM 个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。

输入格式

第一行包含整数 MM,表示操作次数。

接下来 MM 行,每行包含一个操作命令,操作命令为 push xpopemptyquery 中的一种。

输出格式

对于每个 emptyquery 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YESNOquery 操作的查询结果为一个整数,表示队头元素的值。

数据范围

1≤M≤1000001≤M≤100000,
1≤x≤1091≤x≤109,
所有操作保证合法。

输入样例:

10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6

输出样例:

NO
6
YES
4

题解

#include<iostream>
#include<string>
using namespace std;
const int N = 100010;
int q[N], hh, tt = -1;

//向队尾插入一个数
void push(int x){
    q[++tt] = x;
}
//从队头弹出一个数
void pop(){
    ++hh;
}
//判断队列是否为空
void empty(){
    if (hh <= tt) cout << "NO" << endl;
    else cout << "YES" << endl;
}
//查询队头元素
void query(){
    cout << q[hh] << endl;
}

int main(){a
    int m,x;
    string op;
    cin >> m;

    while (m--){
        cin >> op;
        if (op == "push"){
            cin >> x;
            push(x);
        }else if (op == "pop"){
            pop();
        }else if (op == "empty"){
            empty();
        }else{
            query();
        }

    }   
    return 0;
}
0

评论区